Search  
 

Please login to post into the forums. Remember - keep your posts friendly. 

Note: Identic Pty Ltd reserves the right to remove any material it considers inappropriate or offensive. Please report any undesirable posts or behaviour to support@lucidcentral.org.

If you have any direct support requests such as reactivation requests please use the help desk.

  
 

Login

    
 
HomeHomeLucid3 Discussi...Lucid3 Discussi...Lucid FAQsLucid FAQsNew Java Runtime & Older Lucid Applet Player not workingNew Java Runtime & Older Lucid Applet Player not working
Previous
 
Next
New Post
7/3/2013 5:43 PM
 
Applies to: Lucid v3.4 and v3.5 Applet Player based keys deployed on CD/DVD or USB.
Java Runtime Environment: v1.7.0_25
Operating Systems: All

Example Keys Impacted: WATTLE Acacias of Australia; AusGrass; Euclid; Australian Orchid Genera; Families of Flowering Plants of Australia.

Symptoms:
Due to changes in the Java Runtime Environment (JRE), particularly around security, your previously working key may no longer function. The Lucid Applet may fail to load within the browser. Or loads without key data or the tool bar.

Solution:  To correct this you will need to update your keys Lucid Applet Player.

Things to do before updating:
  1. Download and install the latest JRE (if available), free from www.java.com
  2. Set the Java Security to Medium, via the Java Control Panel..See the following URL for details on how to do this: http://www.java.com/en/download/help/...
  3. If you are running Internet Explorer then you should adjust the security to allow active content to run from the local computer. See Internet Options....Advanced Tab..Security section.
  4. Disable pop-up blockers for this content (that is add it to your browsers allow list).
Updating the Lucid Applet
If your key comes on non-writeable media (CD/DVD & some USB keys) you will need to copy all the associated key files and folders to your hard drive or USB key. Next, copy the 'Lucid3PlayerApplet.jar' (download only available to registered users), to the 'lucid_player' folder overwriting the older version.

Start your key, usually via the default.html or start.html page (See your product instructions, if different.). You will now see a number of Java warnings prior to the Lucid Applet Player opening. Depending your your browser and operating system you may get the following warnings:
  • Java needs permission to Run. Choose: 'Run this time.' Or 'Always run on this site.'
  • Security Warning - 'Do you want to run this application?' Choose: Check the 'I accept the risk and want to run this application.'. Then click the 'Run' button.
  • Additional Java Security Warning. Choose: the Run option.
  • You may also receive yet another additional warning to 'Block potentially unsafe components from being run?' Choose: 'Don't Block'.
 
Previous
 
Next
HomeHomeLucid3 Discussi...Lucid3 Discussi...Lucid FAQsLucid FAQsNew Java Runtime & Older Lucid Applet Player not workingNew Java Runtime & Older Lucid Applet Player not working


  
Copyright 2019. All rights reserved. Identic Pty
Terms Of Use  Privacy Statement